Dragon Medical Server – current enhancements to medical vocabulary, acoustic and language models ongoing

Scheduled for Dec 4, 16:50 UTC  -  Dec 15, 22:50 UTC

Update

All datapacks have been successfully deployed, and pre-adaptation is currently in progress. This process is expected to take a few more days and should be completed early next week. Once the process is complete, we’ll provide an update.
Posted Dec 10, 2025 - 15:39 UTC

Scheduled

We are currently deploying new datapacks and expect this process to be completed by Tuesday, 9 December.
In the meantime, we are preparing the profiles and will carry out the final switch without any impact on users.
Posted Dec 04, 2025 - 15:50 UTC