DMO Performance Issues

Resolved

This incident has been resolved.
Posted Apr 18, 2025 - 10:09 UTC

Investigating

We are currently experiencing decreased speech recognition performance and delays. We are investigation the issue.
Posted Apr 18, 2025 - 08:35 UTC
This incident affected: Dragon Medical SpeechKit (Dragon Medical SpeechKit - Speech Recognition, Dragon Medical SpeechKit - Customizations), Dragon Medical One (Dragon Medical One - Login, Dragon Medical One - Speech Recognition, Dragon Medical One - Customization), and PowerMic Mobile, Nuance Management Center.