Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 17, 2025 - 09:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Apr 16, 2025 - 12:39 UTC
Scheduled
The ongoing maintenance will be completed tomorrow 17th April. As announced, during the upcoming days, users may experience temporary decrease in speech recognition accuracy. The full performance will be restored after approximately one day.
Posted Apr 16, 2025 - 14:30 UTC
This scheduled maintenance affected: Dragon Medical SpeechKit (Dragon Medical SpeechKit - Speech Recognition) and Dragon Medical One (Dragon Medical One - Speech Recognition).