There is a current issue with the DMO not working when deployed using ClickOnce

Resolved

The issue has been identified and the problem has been resolved
Posted Jun 02, 2025 - 08:26 UTC

Investigating

We are currently investigating this issue.
Posted Jun 02, 2025 - 07:05 UTC
This incident affected: Dragon Medical One (Dragon Medical One - Login).